CVE-2026-105612
CVE-2026-105612 · PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions
CVSS 3.5 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
postgresql anonymizer
- Versions
- ≥ 1, < 3.3.0: Affected (semver)
Update to 3.3.0