CVE-2026-105782
CVE-2026-105782 · Scrapy: Arbitrary Module Import via Referrer-Policy Header in RefererMiddleware
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Scrapy is a high-level web crawling and scraping framework for Python. From 1.4.0 until 2.14.2, RefererMiddleware in scrapy/spidermiddlewares/referer.py treated a Referrer-Policy response-header value that resembled a Python import path as a referrer policy class, imported the referenced object, and called it. A malicious website could supply a callable such as sys.exit and terminate a crawler processing the response. This issue is fixed in version 2.14.2.
CVSS 7.5 · High · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
scrapy
- Versions
- >= 1.4.0, < 2.14.2: Affected
No fix published
python-scrapy Debian:12
- Versions
- 2.10.0-1
- 2.11.0-1
- 2.11.0-2
- 2.11.1-1
- 2.11.1-2
- 2.11.2-1
- 2.11.2-2
- 2.11.2-3
- 2.12.0-1
- 2.12.0-2
- 2.13.1-1~exp1
- 2.13.3-1
- 2.13.3-1~exp1
- 2.13.4-1
- 2.13.4-2
- 2.14.0-1
- 2.14.1-1
- 2.14.2-1
- 2.15.1-1
- 2.16.0-1
- 2.16.0-2
- 2.17.0-1
- 2.18.0-1
- 2.18.0-2
- 2.19.0-1
- 2.8.0-2
- 2.9.0-1
- 2.9.0-1~exp1
- 2.9.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Debian:13
- Versions
- 2.12.0-2
- 2.13.1-1~exp1
- 2.13.3-1
- 2.13.3-1~exp1
- 2.13.4-1
- 2.13.4-2
- 2.14.0-1
- 2.14.1-1
- 2.14.2-1
- 2.15.1-1
- 2.16.0-1
- 2.16.0-2
- 2.17.0-1
- 2.18.0-1
- 2.18.0-2
- 2.19.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Debian:14
- Versions
- 2.12.0-2
- 2.13.1-1~exp1
- 2.13.3-1
- 2.13.3-1~exp1
- 2.13.4-1
- 2.13.4-2
- 2.14.0-1
- 2.14.1-1
- Affected ranges
- ECOSYSTEM: < 2.14.2-1
Update to 2.14.2-1
scrapy PyPI
- Versions
- 1.4.0
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 2.0.0
- 2.0.1
- 2.1.0
- 2.10.0
- 2.10.1
- 2.11.0
- 2.11.1
- 2.11.2
- 2.12.0
- 2.13.0
- 2.13.1
- 2.13.2
- 2.13.3
- 2.13.4
- 2.14.0
- 2.14.1
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.4.1
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.8.0
- 2.9.0
- Affected ranges
- ECOSYSTEM: ≥ 1.4.0, < 2.14.2
Update to 2.14.2
python-scrapy Ubuntu:16.04:LTS
- Versions
- 1.0.0-1
- 1.0.3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Ubuntu:Pro:18.04:LTS
- Versions
- 1.3.0-1~exp2
- 1.4.0-1
- 1.5.0-1
- 1.5.0-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Ubuntu:Pro:20.04:LTS
- Versions
- 1.7.3-1
- 1.7.3-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Ubuntu:Pro:22.04:LTS
- Versions
- 2.4.1-2
- 2.5.1-2
- 2.5.1-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Ubuntu:Pro:24.04:LTS
- Versions
- 2.10.0-1
- 2.11.0-1
- 2.11.0-2
- 2.11.1-1
- 2.11.1-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-scrapy Ubuntu:26.04:LTS
- Versions
- 2.12.0-2
- 2.14.0-1
- 2.14.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/scrapy/scrapy/security/advisories/GHSA-cwxj-rr6w-m6w7
- https://github.com/scrapy/scrapy/commit/945b787a263586cb5803c01c6da57daad8997ae5
- https://github.com/scrapy/scrapy/commit/b6e5c58ae707a3d4bb491537b5519534050047e0
- https://github.com/scrapy/scrapy/releases/tag/2.14.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-105782