p PatchFirst

CVE-2026-105855

CVE-2026-105855 · Payload: Field-level password update restrictions were not enforced

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, the server fails to enforce a field-level access.update restriction on the password field of an authentication collection. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

CVSS 7.6 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • payload

    Versions
    • < 3.90.0: Affected
    • >= 4.0.0-canary.0, < 4.0.0-canary.34: Affected

    No fix published

  • payload npm

    Affected ranges
    • SEMVER: < 3.90.0

    Update to 3.90.0

  • payload npm

    Affected ranges
    • SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34

    Update to 4.0.0-canary.34

Original sources

Check your server →