CVE-2026-106459
CVE-2026-106459 · Backstage: Improper input validation in Sentry scaffolder actions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.
CVSS 8.5 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- >= 1.47.0, < 1.54.8: Affected
No fix published
plugin-scaffolder-backend-module-sentry
- Versions
- >= 0.3.0, < 0.3.8: Affected
No fix published
@backstage/plugin-scaffolder-backend-module-sentry npm
- Affected ranges
- SEMVER: ≥ 0.3.0, < 0.3.8
Update to 0.3.8
Original sources
- https://github.com/backstage/backstage/security/advisories/GHSA-g734-fhp4-7mfp
- https://github.com/backstage/backstage/commit/b0170fad7962fb8c3d71366b5265cf283c7bbcf7
- https://github.com/backstage/backstage/releases/tag/v1.54.8
- https://github.com/backstage/backstage/releases/tag/v1.55.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-106459