CVE-2026-106557
CVE-2026-106557 · Backstage: Improper input validation in TechDocs Markdown extension configuration
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open framework for building developer portals. Prior to 1.14.6 and 1.15.4, the @backstage/plugin-techdocs-node package did not sufficiently validate TechDocs Markdown extension configuration. An authenticated user who can register or modify documentation sources may cause a TechDocs build to access resources outside the intended documentation boundary, potentially exposing backend-host data or internal network resources. This issue is fixed in versions 1.14.6 and 1.15.4 when pymdown-extensions 10.21.3 or later is also used, normally through mkdocs-techdocs-core 1.7.0 or later.
CVSS 7.7 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- < 1.50.5: Affected
- >= 1.51.0-next.0, < 1.54.6: Affected
No fix published
plugin-techdocs-node
- Versions
- < 1.14.6: Affected
- >= 1.15.0, < 1.15.4: Affected
No fix published
@backstage/plugin-techdocs-node npm
- Affected ranges
- SEMVER: < 1.15.4
Update to 1.15.4
Original sources
- https://github.com/backstage/backstage/security/advisories/GHSA-f7v3-xhm6-w245
- https://github.com/backstage/backstage/commit/017ace52d9b327ededc6704cf17799c875ae0f29
- https://github.com/backstage/backstage/commit/2d9de4ca117a529de4b6ed7dfb7aa507ca7b3f91
- https://github.com/backstage/backstage/releases/tag/v1.50.5
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://nvd.nist.gov/vuln/detail/CVE-2026-106557