CVE-2026-106563
CVE-2026-106563 · Backstage: Improper entity validation in deprecated Kubernetes services endpoint
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.
CVSS 5.3 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- < 1.54.1: Affected
No fix published
plugin-kubernetes-backend
- Versions
- < 0.21.8: Affected
No fix published
@backstage/plugin-kubernetes-backend npm
- Affected ranges
- SEMVER: < 0.21.8
Update to 0.21.8