CVE-2026-109090
CVE-2026-109090 · libXi XGetDeviceControl DEVICE_ENABLE Heap Buffer Overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when processed by libXi before 1.8.4.
CVSS 7.5 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libxi
- Versions
- ≥ 0, < 1.8.4: Affected (rpm)
Update to 1.8.4
libxi Debian:12
- Versions
- 2:1.8-1
- 2:1.8-1+hurd.1
- 2:1.8.1-1
- 2:1.8.2-1
- 2:1.8.2-2
- 2:1.8.3-1
- 2:1.8.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Debian:13
- Versions
- 2:1.8.2-1
- 2:1.8.2-2
- 2:1.8.3-1
- 2:1.8.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Debian:14
- Versions
- 2:1.8.2-1
- 2:1.8.2-2
- 2:1.8.3-1
- 2:1.8.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:Pro:16.04:LTS
- Versions
- 2:1.7.4-1
- 2:1.7.5-1
- 2:1.7.6-1
- 2:1.7.6-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:18.04:LTS
- Versions
- 2:1.7.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:20.04:LTS
- Versions
- 2:1.7.10-0ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:22.04:LTS
- Versions
- 2:1.7.10-1build2
- 2:1.7.10-1build3
- 2:1.8-1
- 2:1.8-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:24.04:LTS
- Versions
- 2:1.8-1build1
- 2:1.8.1-1
- 2:1.8.1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:26.10
- Versions
- 2:1.8.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxi Ubuntu:26.04:LTS
- Versions
- 2:1.8.2-1
- 2:1.8.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published