p PatchFirst

CVE-2026-1092

CVE-2026-1092 · Improper Validation of Specified Quantity in Input in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.10 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an unauthenticated user to cause denial of service due to improper input validation of JSON payloads.

CVSS 7.5 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 12.10, < 18.8.9: Affected (semver)
    • ≥ 18.9, < 18.9.5: Affected (semver)
    • ≥ 18.10, < 18.10.3: Affected (semver)

    Update to 18.10.3; Update to 18.8.9; Update to 18.9.5

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →