CVE-2026-109346
CVE-2026-109346 · better-auth 1.3.8-beta.3 before 1.7.0-rc.3 Device Authorization Phishing via /device
This page contains facts from public vulnerability sources. Check the original advisory before updating.
better-auth from 1.3.8-beta.3 before 1.7.0-rc.3 contains a UI misrepresentation vulnerability in the deviceAuthorization plugin because GET /device omits the requesting client_id and scope. Attackers can start a device request via /device/code, trick signed-in users into approving the code, then redeem it at /device/token for a live session token.
CVSS 8.5 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
better-auth
- Versions
- ≥ 1.3.8-beta.3, < 1.7.0-rc.3: Affected (semver)
- 1.7.0-rc.3: Not affected (semver)
Update to 1.7.0-rc.3
better-auth npm
- Affected ranges
- SEMVER: ≥ 1.3.8-beta.3, < 1.7.0-rc.3
Update to 1.7.0-rc.3