CVE-2026-1094
CVE-2026-1094 · Improper Validation of Unsafe Equivalence in Input in GitLab
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.8 before 18.8.4 that could have allowed an authenticated developer to hide specially crafted file changes from the WebUI.
CVSS 4.6 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gitlab
- Versions
- ≥ 18.8, < 18.8.4: Affected (semver)
Update to 18.8.4
gitlab Ubuntu:16.04:LTS
- Versions
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:24.04:LTS
- Versions
- 14.1.0-1
- 16.1.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:25.10
- Versions
- 16.1.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:26.10
- Versions
- 16.1.3-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:26.04:LTS
- Versions
- 16.1.3-2
- 16.1.3-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published