p PatchFirst

CVE-2026-110005

CVE-2026-110005 · Moghtech Komodo contains an OS command injection vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The `periphery` agent's container-management functionality of Komodo version 2.2.0 contains an OS command injection vulnerability. An authenticated low-privileged user with `Execute`, or `Read` plus `Logs`, permission on a managed server can supply shell metacharacters in a container name processed by the `DestroyContainer` or `SearchContainerLog` operations. The container name is interpolated without escaping into a command executed using `sh -c`, allowing arbitrary commands to execute as root on the managed host. This permits a user without Komodo's `Terminal` permission to obtain unrestricted host-level command execution.

CVSS 8.8 · High · EPSS 2.2% · Fix available

Published
Updated

Affected products and versions

  • komodo

    Versions
    • ≥ 1.19.1, < 2.3.0: Affected (custom)

    Update to 2.3.0

Original sources

Check your server →