p PatchFirst

CVE-2026-111074

CVE-2026-111074 · JITServer: Pre-authentication remote Denial of Service via integer overflow infinite loop in MessageBuffer::computeRequiredCapacity()

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component is vulnerable to a pre-authentication remote denial of service. When processing the initial 4-byte length field of an incoming TCP connection, an integer overflow in `MessageBuffer::computeRequiredCapacity()` causes the receiving compilation worker thread to enter an infinite loop consuming ~100% CPU. An unauthenticated remote attacker can exploit this by opening a small number of crafted TCP connections to exhaust the entire worker thread pool, silently halting compilation services for all connected client JVMs.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • eclipse openj9

    Versions
    • ≥ 0.8.0, < 0.63: Affected (semver)

    Update to 0.63

Original sources

Check your server →