p PatchFirst

CVE-2026-111664

CVE-2026-111664 · Safing Portmaster before 2.2.5 Unauthenticated Forced Downgrade via /api/v1/updates/from-url

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Safing Portmaster before 2.2.5 contains a missing authorization vulnerability that allows unprivileged local processes to force updates by calling the POST /api/v1/updates/from-url endpoint registered with api.PermitAnyone. Attackers can supply an attacker-controlled index URL that bypasses version checks and auto-apply settings, installing older Safing-signed releases carrying previously fixed vulnerabilities.

CVSS 4.8 · Medium · EPSS 0.1% · Fix available

Published
Updated

Affected products and versions

  • portmaster

    Versions
    • ≥ 0, < 2.2.5: Affected (custom)

    Update to 2.2.5

Original sources

Check your server →