p PatchFirst

CVE-2026-111888

CVE-2026-111888 · phpMyFAQ 4.0.0 before 4.1.9 Incorrect Authorization via news update API

This page contains facts from public vulnerability sources. Check the original advisory before updating.

phpMyFAQ from 4.0.0 before 4.1.9 contains an incorrect authorization vulnerability that allows delegated admins lacking the editnews right to modify news by calling PUT /admin/api/news/update, which checks NEWS_DELETE instead of NEWS_EDIT. Attackers holding addnews and delnews can read the update-news CSRF token from their own cookie and rewrite any news item's header, body, author, link and active flag shown on the public front page.

CVSS 5.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Affected products and versions

  • phpmyfaq

    Versions
    • ≥ 4.0.0, < 4.1.9: Affected (semver)
    • 4.1.9: Not affected (semver)

    Update to 4.1.9

Original sources

Check your server →