CVE-2026-111890
CVE-2026-111890 · phpMyFAQ 4.2.0-alpha.2 before 4.2.0-beta Privilege Escalation via updateUserRights
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta contains a privilege escalation vulnerability in UserController::updateUserRights that drops per-right language restrictions when rights are re-granted. Administrators holding USER_EDIT can submit language-scoped rights to the update-rights API, including for themselves, to gain unrestricted FAQ create, edit, and publish access across all languages.
CVSS 7.0 · High · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
phpmyfaq
- Versions
- ≥ 4.2.0-alpha.2, < 4.2.0-beta: Affected (semver)
- 4.2.0-beta: Not affected (semver)
Update to 4.2.0-beta