CVE-2026-111891
CVE-2026-111891 · phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta Privilege Escalation via Group Permissions API
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta contains a privilege escalation vulnerability in the group permission API, whose updatePermissions and updateMembers endpoints check held rights without regard to language or category scope and write unrestricted group grants. Non-superadmin administrators holding GROUP_EDIT can grant a group a right they hold only in a narrow scope and self-join it via updateMembers, gaining unrestricted FAQ create, edit, and publish access across all languages and categories.
CVSS 7.0 · High · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
phpmyfaq
- Versions
- ≥ 4.2.0-alpha.2, < 4.2.0-beta: Affected (semver)
- 4.2.0-beta: Not affected (semver)
Update to 4.2.0-beta