p PatchFirst

CVE-2026-111894

CVE-2026-111894 · phpMyFAQ 3.2.1 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta Stored XSS via iframe data: URI

This page contains facts from public vulnerability sources. Check the original advisory before updating.

phpMyFAQ 3.2.1 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a stored cross-site scripting vulnerability that allows authenticated content authors to inject JavaScript by embedding iframes with data:text/html sources in FAQ or News content. Attackers can bypass the hostless media-host allowlist in FaqHelper::cleanUpContent(), which is rendered via Twig's raw filter, to run phishing interfaces or top-frame redirects for viewers.

CVSS 5.1 · Medium · EPSS 0.2% · Fix available

Published
Updated

Affected products and versions

  • phpmyfaq

    Versions
    • ≥ 3.2.1, < 4.1.9: Affected (semver)
    • 4.1.9: Not affected (semver)

    Update to 4.1.9

  • phpmyfaq

    Versions
    • ≥ 4.2.0-alpha, < 4.2.0-beta: Affected (semver)
    • 4.2.0-beta: Not affected (semver)

    Update to 4.2.0-beta

Original sources

Check your server →