p PatchFirst

CVE-2026-111904

CVE-2026-111904 · phpMyFAQ 4.2.0-alpha before 4.2.0-beta Information Disclosure via open-questions API

This page contains facts from public vulnerability sources. Check the original advisory before updating.

phpMyFAQ 4.2.0-alpha before 4.2.0-beta contains an information disclosure vulnerability that allows unauthenticated attackers to read hidden open questions due to an inverted api.onlyPublicQuestions check in OpenQuestionController. Attackers can send GET requests to the /api/v4.0/open-questions endpoint to retrieve non-public moderation or internal questions and their associated usernames.

CVSS 6.9 · Medium · EPSS 0.3% · Fix available

Published
Updated

Affected products and versions

  • phpmyfaq

    Versions
    • ≥ 4.2.0-alpha, < 4.2.0-beta: Affected (semver)
    • 4.2.0-beta: Not affected (semver)

    Update to 4.2.0-beta

Original sources

Check your server →