p PatchFirst

CVE-2026-111906

CVE-2026-111906 · phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta CSRF in Elasticsearch/OpenSearch Admin API Index Operations

This page contains facts from public vulnerability sources. Check the original advisory before updating.

phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a cross-site request forgery vulnerability in the Elasticsearch and OpenSearch administration API endpoints, which do not validate a CSRF token for the create, drop, and import actions. Attackers can lure a user with CONFIGURATION_EDIT permission to a malicious page that triggers these actions, deleting search indexes, forcing re-indexing, or exhausting resources.

CVSS 7.1 · High · EPSS 0.2% · Fix available

Published
Updated

Affected products and versions

  • phpmyfaq

    Versions
    • ≥ 0, < 4.1.9: Affected (semver)
    • 4.1.9: Not affected (semver)

    Update to 4.1.9

  • phpmyfaq

    Versions
    • ≥ 4.2.0-alpha, < 4.2.0-beta: Affected (semver)
    • 4.2.0-beta: Not affected (semver)

    Update to 4.2.0-beta

Original sources

Check your server →