p PatchFirst

CVE-2026-111907

CVE-2026-111907 · phpMyFAQ 4.0.0 before 4.1.9 CSRF via /admin/api/update-database

This page contains facts from public vulnerability sources. Check the original advisory before updating.

phpMyFAQ 4.0.0 before 4.1.9 contains a cross-site request forgery vulnerability in the POST /admin/api/update-database endpoint, which executes database migrations without validating a CSRF token. Attackers can lure a logged-in user with the CONFIGURATION_EDIT permission into submitting a crafted cross-site request, triggering migrations that may impact database integrity or availability.

CVSS 7.1 · High · EPSS 0.1% · Fix available

Published
Updated

Affected products and versions

  • phpmyfaq

    Versions
    • ≥ 4.0.0, < 4.1.9: Affected (semver)
    • 4.1.9: Not affected (semver)

    Update to 4.1.9

Original sources

Check your server →