p PatchFirst

CVE-2026-111924

CVE-2026-111924 · Fleet before 4.83.0 Denial of Service via Unbounded Gzip Decompression

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Fleet before 4.83.0 contains a denial of service vulnerability that allows unauthenticated attackers to exhaust server memory by sending gzip-compressed request bodies. Attackers can send small, highly compressed requests with Content-Encoding: gzip to unauthenticated endpoints that expand during decoding, crashing the entire Fleet instance.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • fleet

    Versions
    • ≥ 0, < 4.83.0: Affected (semver)
    • 4.83.0: Not affected (semver)

    Update to 4.83.0

Original sources

Check your server →