CVE-2026-112328
CVE-2026-112328 · Sensei LMS 4.26.4 Broken Access Control via add_new_module_term AJAX
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Sensei LMS WordPress plugin before 4.26.4 contains a broken access control vulnerability in the add_new_module_term AJAX handler that allows authenticated Teacher-role attackers to assign module taxonomy terms to arbitrary courses by supplying a crafted course_id, since the handler validates only a generic nonce and checks manage_options solely for slug prefixing rather than verifying course edit permissions. Attackers can reuse a nonce obtained from their own course metabox to call wp_set_object_terms against courses owned by other teachers or administrators, enabling unauthorized modification of course content they do not own.
CVSS 5.3 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
sensei lms
- Versions
- ≥ 0, < 4.26.4: Affected (semver)
Update to 4.26.4