p PatchFirst

CVE-2026-112329

CVE-2026-112329 · Sensei LMS 4.26.4 Broken Access Control via save_new_message

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Sensei LMS WordPress plugin before 4.26.4 contains a broken access control vulnerability in the legacy save_new_message handler hooked on the init action, which validates only a generic nonce without verifying course enrollment or restricting post_id to valid post types. Authenticated attackers, including unprivileged Subscribers, can supply an arbitrary post_id for any course, lesson, or quiz to create a private message addressed to that post's author, bypassing the enrollment checks enforced by the newer REST send-message controller.

CVSS 5.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Affected products and versions

  • sensei lms

    Versions
    • ≥ 0, < 4.26.4: Affected (semver)

    Update to 4.26.4

Original sources

Check your server →