p PatchFirst

CVE-2026-112362

CVE-2026-112362 · @fastify/express vulnerable to path-scoped middleware bypass via absolute-form request targets

This page contains facts from public vulnerability sources. Check the original advisory before updating.

@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.

CVSS 9.1 · Critical · Fix available

Published
Updated

Affected products and versions

  • @fastify/express

    Versions
    • ≥ 4.0.5, < 4.0.9: Affected (semver)
    • 4.0.9: Not affected (semver)

    Update to 4.0.9

Original sources

Check your server →