CVE-2026-112957
CVE-2026-112957 · ApostropheCMS: GET /api/v1/@apostrophecms/page/:id bypasses viewRole restriction and exposes viewPermission-gated fields to lower-privileged users
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, the getOne REST endpoint for pages does not apply viewRole type-level restrictions or viewPermission field-level redaction. An editor-level user who knows a document _id can read the full content of admin-only pages and their privileged fields, while the getAll endpoint correctly enforces both restrictions. This issue is fixed in version 4.34.0.
CVSS 4.3 · Medium · EPSS 0.3% · Public exploit · Fix available
- Published
- Updated
Stack: node
Affected products and versions
apostrophe
- Versions
- < 4.34.0: Affected
No fix published
apostrophe npm
- Affected ranges
- SEMVER: < 4.34.0
Update to 4.34.0
Original sources
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-vh56-5m88-39rq
- https://github.com/apostrophecms/apostrophe/commit/06e4b377f3c360f9e89c32dccd7e505ad5ddf498
- https://github.com/apostrophecms/apostrophe/commit/40b989b1a9dd23d30029b8ce7668634265cfe5ea
- https://github.com/apostrophecms/apostrophe/releases/tag/[email protected]
- https://nvd.nist.gov/vuln/detail/CVE-2026-112957