p PatchFirst

CVE-2026-113610

CVE-2026-113610 · Xen Orchestra before 6.9.0 Authorization Bypass via user.set API

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Xen Orchestra before 6.9.0 contains an authorization bypass vulnerability in the xo-server user.set API method that allows low-privileged authenticated users to modify other users' preferences by supplying an arbitrary target user id. Attackers can delete the preferences.otp TOTP secret to disable two-factor authentication, corrupt it to block logins, or overwrite stored xsCredentials and sshKeys.

CVSS 5.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • xen-orchestra

    Versions
    • ≥ 0, < 6.9.0: Affected (semver)

    Update to 6.9.0

Original sources

Check your server →