p PatchFirst

CVE-2026-114059

CVE-2026-114059 · ArcadeDB before 26.10.1 RCE via Gremlin Groovy Engine Missing Authorization

This page contains facts from public vulnerability sources. Check the original advisory before updating.

ArcadeDB before 26.10.1 contains a remote code execution vulnerability that allows authenticated users, including read-only reader role holders, to execute Groovy code because GremlinQueryEngine.command() lacks scripting authorization checks. Attackers can submit Gremlin commands to the POST /api/v1/command/{database} endpoint when the Groovy engine is enabled to run OS commands as the server process user.

CVSS 7.7 · High · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • arcadedb

    Versions
    • ≥ 0, < 26.10.1: Affected (semver)
    • 26.10.1: Not affected (semver)

    Update to 26.10.1

Original sources

Check your server →