p PatchFirst

CVE-2026-114112

CVE-2026-114112 · Sharp before 0.35.4 RCE via bundled libheif AVIF decoding

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Sharp before 0.35.4 bundles a vulnerable libheif dependency that allows attackers to achieve possible remote code execution on glibc-based Linux by supplying crafted images. Attackers can submit malicious AVIF/HEIF input to applications processing untrusted images with sharp, triggering libheif decoding flaws to execute code.

CVSS 8.9 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • sharp

    Versions
    • ≥ 0, < 0.35.4: Affected (semver)
    • 0.35.4: Not affected (semver)

    Update to 0.35.4

  • sharp npm

    Affected ranges
    • SEMVER: < 0.35.4

    Update to 0.35.4

Original sources

Check your server →