CVE-2026-114386
CVE-2026-114386 · Pydantic AI Harness before 0.59.0 CodeMode Tool Call Limit Bypass via run_code
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Pydantic AI Harness before 0.59.0 fails to enforce UsageLimits.tool_calls_limit on nested tool calls dispatched from run_code in the CodeMode toolset. Users or prompt-injected content can make the sandboxed program invoke tools via run_nested_call() without check_before_tool_call, exceeding operator limits on costly or side-effecting tools.
CVSS 6.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
pydantic-ai-harness
- Versions
- ≥ 0, < 0.59.0: Affected (semver)
Update to 0.59.0
pydantic-ai-harness PyPI
- Versions
- 0.1.1
- 0.1.2
- 0.10.0
- 0.11.0
- 0.12.0
- 0.13.0
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.18.0
- 0.18.1
- 0.2.0
- 0.2.1
- 0.20.0
- 0.21.0
- 0.22.0
- 0.23.0
- 0.24.0
- 0.25.0
- 0.26.0
- 0.27.0
- 0.28.0
- 0.28.1
- 0.29.0
- 0.29.1
- 0.3.0
- 0.30.0
- 0.31.0
- 0.32.0
- 0.33.0
- 0.34.0
- 0.35.0
- 0.36.0
- 0.4.0
- 0.5.0
- 0.52.0
- 0.53.0
- 0.54.0
- 0.55.0
- 0.56.0
- 0.57.0
- 0.58.0
- 0.6.0
- 0.7.0
- 0.7.1
- 0.8.0
- 0.9.0
- Affected ranges
- ECOSYSTEM: < 0.59.0
Update to 0.59.0
Original sources
- https://github.com/pydantic/pydantic-ai/pull/10362
- https://github.com/pydantic/pydantic-ai/commit/eb27b2b89fe76ae23ee9b6fc9eb4b227a4967949
- https://github.com/pydantic/pydantic-ai/releases/tag/v2.59.0
- https://github.com/pydantic/pydantic-ai/blob/v2.58.0/src/pydantic_ai_harness/pydantic_ai_harness/code_mode/_toolset.py#L642-L680
- https://pypi.org/project/pydantic-ai-harness/0.59.0/
- https://www.vulncheck.com/advisories/pydantic-ai-harness-before-0.59.0-codemode-tool-call-limit-bypass-via-run-code
- https://nvd.nist.gov/vuln/detail/CVE-2026-114386