CVE-2026-114531
CVE-2026-114531 · DRUPAL-CONTRIB-2026-228
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The module provides integration with third party JS library SwiperJs. User-entered text is used as part of the slide without appropriate filtering leading to a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker would need a role with permission to edit the caption.
Fix available
- Published
- Updated
Stack: php
Affected products and versions
drupal/swiper_formatter Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 2.1.2
- ECOSYSTEM: ≥ 3.0.1, < 3.1.0
Update to 2.1.2; Update to 3.1.0