CVE-2026-115419
CVE-2026-115419 · Unintended disclosure of data element to wrong session in Strands Agents SDK A2A Server
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The A2A server component in Amazon Strands Agents SDK for Python before 1.43.0 and Amazon Strands Agents SDK for TypeScript before 1.5.0 does not properly isolate conversation state between callers. An authenticated remote user could read other tenants' conversation history and add persistent instructions that alter model behavior for subsequent callers via HTTP requests to the A2A endpoint using a different context_id. To mitigate this issue, users should upgrade to strands-agents 1.43.0 (Python) or @strands-agents/sdk 1.5.0 (TypeScript).
CVSS 8.6 · High · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
strands-agents
- Versions
- ≥ 0, < 1.43.0: Affected (custom)
Update to 1.43.0
strands-agents/sdk
- Versions
- ≥ 0, < 1.5.0: Affected (custom)
Update to 1.5.0
strands-agents PyPI
- Versions
- 0.0.1
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.3.0
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.11.0
- 1.12.0
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18.0
- 1.19.0
- 1.2.0
- 1.20.0
- 1.21.0
- 1.22.0
- 1.23.0
- 1.24.0
- 1.25.0
- 1.26.0
- 1.27.0
- 1.28.0
- 1.29.0
- 1.3.0
- 1.30.0
- 1.31.0
- 1.32.0
- 1.33.0
- 1.34.0
- 1.34.1
- 1.35.0
- 1.36.0
- 1.37.0
- 1.38.0
- 1.39.0
- 1.4.0
- 1.40.0
- 1.41.0
- 1.42.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 1.9.1
- Affected ranges
- ECOSYSTEM: < 1.43.0
Update to 1.43.0
@strands-agents/sdk npm
- Affected ranges
- SEMVER: < 1.5.0
Update to 1.5.0
Original sources
- https://pypi.org/project/strands-agents/1.43.0/
- https://www.npmjs.com/package/@strands-agents/sdk/v/1.5.0
- https://aws.amazon.com/security/security-bulletins/2026-146-aws/
- https://github.com/strands-agents/harness-sdk/security/advisories/GHSA-4v6f-7vjh-6x4m
- https://nvd.nist.gov/vuln/detail/CVE-2026-115419