CVE-2026-11564
CVE-2026-11564 · Native CA trust persist
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libcurl keeps previously used connections in a connection pool for subsequent transfers to reuse if one of them matches the setup. An easy handle that first uses default native CA trust can continue trusting the native platform store after the application switches that same handle to custom CA material for a later transfer.
CVSS 9.1 · Critical · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
curl
- Versions
- ≥ 8.17.0, < 8.20.1: Affected (semver)
Update to 8.20.1
curl
- Versions
- ≥ eefd03c572996e5de4dec4fe295ad6f103e0eefc, < d69bfad3fa3daf5e72331f6870667607828d5891: Affected (git)
No fix published
curl
- Versions
- 8.20.0: Affected
- 8.19.0: Affected
- 8.18.0: Affected
- 8.17.0: Affected
No fix published
curl Debian:14
- Versions
- 8.14.1-2
- 8.14.1-2+exp1
- 8.15.0-1
- 8.15.0-1~bpo13+1
- 8.15.0-1~exp1
- 8.15.0~rc1-1exp1
- 8.15.0~rc2-1~exp1
- 8.15.0~rc3-1~exp1
- 8.16.0-1
- 8.16.0-1+exp1
- 8.16.0-1~bpo13+1
- 8.16.0-2
- 8.16.0-3
- 8.16.0-4
- 8.16.0-4~bpo13+1
- 8.16.0~rc1-1~exp1
- 8.16.0~rc2-1
- 8.16.0~rc2-2
- 8.16.0~rc3-1
- 8.17.0-1
- 8.17.0-2
- 8.17.0-3
- 8.17.0~rc1-1~exp1
- 8.17.0~rc2-1
- 8.17.0~rc3-1
- 8.18.0-1
- 8.18.0-1~bpo13+1
- 8.18.0-2
- 8.18.0~rc1-1+exp1
- 8.18.0~rc2-1
- 8.18.0~rc3-1
- 8.19.0-1
- 8.19.0-1+exp1
- 8.19.0-1~bpo13+1
- 8.19.0-2
- 8.19.0-3
- 8.19.0-3+exp1
- 8.19.0-3+exp2
- 8.19.0~rc1-1~exp1
- 8.19.0~rc2-1
- 8.19.0~rc2-2
- 8.19.0~rc3-1
- 8.20.0-1
- 8.20.0-1+exp
- 8.20.0-2
- 8.20.0-2+exp1
- 8.20.0-2~bpo13+1
- 8.20.0-3
- 8.20.0-4
- 8.20.0-5
- 8.20.0-5~bpo13+1
- 8.20.0~rc1-1+exp1
- 8.20.0~rc1-1+exp2
- 8.20.0~rc1-1+exp3
- 8.20.0~rc2-1
- 8.20.0~rc2-1+exp1
- 8.20.0~rc3-1
- 8.20.0~rc3-1+exp1
- 8.21.0~rc1-1+exp1
- Affected ranges
- ECOSYSTEM: < 8.21.0~rc2-1
Update to 8.21.0~rc2-1
curl Ubuntu:26.04:LTS
- Versions
- 8.14.1-2ubuntu1
- 8.17.0-1ubuntu1
- 8.18.0-1ubuntu1
- 8.18.0-1ubuntu2
- 8.18.0-1ubuntu2.1
- 8.18.0-1ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 8.18.0-1ubuntu2.3
Update to 8.18.0-1ubuntu2.3