CVE-2026-115914
CVE-2026-115914 · vLLM DeepSeek-OCR image processing vulnerable to denial of service
This page contains facts from public vulnerability sources. Check the original advisory before updating.
vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.
CVSS 6.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vllm
- Versions
- >= 0.11.1, < 0.32.0: Affected
No fix published
vllm PyPI
- Versions
- 0.11.1
- 0.11.2
- 0.12.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.16.0
- 0.17.0
- 0.17.1
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.22.0
- 0.22.1
- 0.23.0
- 0.24.0
- 0.25.0
- 0.25.1
- 0.26.0
- 0.27.0
- 0.27.1
- 0.28.0
- 0.29.0
- 0.30.0
- 0.31.0
- Affected ranges
- ECOSYSTEM: ≥ 0.11.1, < 0.32.0
Update to 0.32.0
Original sources
- https://github.com/vllm-project/vllm/security/advisories/GHSA-gq5q-89c7-vhvx
- https://github.com/vllm-project/vllm/pull/59417
- https://github.com/vllm-project/vllm/commit/c15672cfb49152ebf65cfd188e71b84593ec5686
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-115914