CVE-2026-115917
CVE-2026-115917 · vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
This page contains facts from public vulnerability sources. Check the original advisory before updating.
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
CVSS 3.4 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vllm
- Versions
- < 0.32.0: Affected
No fix published
vllm PyPI
- Versions
- 0.0.1
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.10.0
- 0.10.1
- 0.10.1.1
- 0.10.2
- 0.11.0
- 0.11.1
- 0.11.2
- 0.12.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.16.0
- 0.17.0
- 0.17.1
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.2.0
- 0.2.1
- 0.2.1.post1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.22.0
- 0.22.1
- 0.23.0
- 0.24.0
- 0.25.0
- 0.25.1
- 0.26.0
- 0.27.0
- 0.27.1
- 0.28.0
- 0.29.0
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.30.0
- 0.31.0
- 0.4.0
- 0.4.0.post1
- 0.4.1
- 0.4.2
- 0.4.3
- 0.5.0
- 0.5.0.post1
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.3.post1
- 0.5.4
- 0.5.5
- 0.6.0
- 0.6.1
- 0.6.1.post1
- 0.6.1.post2
- 0.6.2
- 0.6.3
- 0.6.3.post1
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- 0.9.0
- 0.9.0.1
- 0.9.1
- 0.9.2
- Affected ranges
- ECOSYSTEM: < 0.32.0
Update to 0.32.0
Original sources
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh
- https://github.com/vllm-project/vllm/pull/61009
- https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-115917