CVE-2026-115922
CVE-2026-115922 · ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to 1.22.0, _unpack_2bit() and _unpack_4bit() resize unpacked arrays according to attacker-controlled TensorProto.dims without verifying that raw_data or int32_data encodes the declared number of elements. Materializing an untrusted UINT2, INT2, UINT4, INT4, or FLOAT4E2M1 tensor through onnx.numpy_helper.to_array() or onnx.reference.ReferenceEvaluator can therefore expand a small packed payload into a disproportionately large allocation and exhaust memory. This issue is fixed in version 1.22.0.
CVSS 6.2 · Medium · EPSS 0.1% · Fix available
- Published
- Updated
Affected products and versions
onnx
- Versions
- < 1.22.0: Affected
No fix published
onnx Debian:12
- Versions
- 1.12.0-2
- 1.13.1-1
- 1.13.1-2
- 1.13.1-3
- 1.14.1-1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1~exp1
- 1.16.1-1
- 1.16.2-1
- 1.17.0-1
- 1.17.0-2
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Debian:13
- Versions
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Debian:14
- Versions
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx PyPI
- Versions
- 0.1
- 0.2
- 0.2.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.16.2
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.19.1rc1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.1
- 1.20.1rc1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.0rc4
- 1.22.0rc1
- 1.22.0rc2
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.22.0
Update to 1.22.0
onnx Ubuntu:22.04:LTS
- Versions
- 1.7.0+dfsg-3build1
- 1.7.0+dfsg-3build2
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:Pro:24.04:LTS
- Versions
- 1.13.1-3
- 1.13.1-3build1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1build1
- 1.14.1-2.1build2
- 1.14.1-2.1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:26.10
- Versions
- 1.20.0-1
- 1.20.0-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:26.04:LTS
- Versions
- 1.17.0-3build1
- 1.20.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/onnx/onnx/security/advisories/GHSA-q69g-f4f5-v8m7
- https://github.com/onnx/onnx/pull/8033
- https://github.com/onnx/onnx/pull/8038
- https://github.com/onnx/onnx/pull/8066
- https://github.com/onnx/onnx/commit/05c1bc3bceceb8d3cf11e9e7fc7f19f971c44988
- https://github.com/onnx/onnx/commit/8de2cf6aa47928e6515ac6d9e1a8b4758886a7df
- https://github.com/onnx/onnx/commit/dce5876d6cc6cc30157af7d26a752ef44976da8e
- https://github.com/onnx/onnx/releases/tag/v1.22.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-115922