p PatchFirst

CVE-2026-116011

CVE-2026-116011 · Crow before 1.3.4 Denial of Service via Deeply Nested JSON in crow::json::load()

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Crow before 1.3.4 contains an uncontrolled recursion vulnerability in crow::json::load() that allows remote unauthenticated attackers to crash the server by sending deeply nested JSON. Attackers can send a request body with thousands of nested objects to exhaust the worker thread stack, terminating the process and dropping all connections.

CVSS 8.7 · High · EPSS 0.7% · Public exploit · Fix available

Published
Updated

Affected products and versions

  • crow

    Versions
    • ≥ 0, < 1.3.4: Affected (semver)

    Update to 1.3.4

Original sources

Check your server →