p PatchFirst

CVE-2026-116019

CVE-2026-116019 · Grav 2.0.15 before 2.2.13 Allowlist Bypass via Flex Form Override Directives

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Grav 2.0.15 before 2.2.13 contains an allowlist bypass vulnerability that allows page editors to invoke arbitrary public static methods by relocating data-*@ directives with unset-name@ or integer keys. Attackers with page-edit permission can embed crafted fields in Flex form overrides in page frontmatter to call methods like Folder::delete or Utils::download, deleting directories, overwriting files, or reading files outside the page tree.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Affected products and versions

  • grav

    Versions
    • ≥ 2.0.15, < 2.2.13: Affected (semver)

    Update to 2.2.13

Original sources

Check your server →