p PatchFirst

CVE-2026-116173

CVE-2026-116173 · vLLM 0.22.0 before 0.24.0 Denial of Service via gRPC output_candidates.token_ids

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM from 0.22.0 before 0.24.0 contains a denial of service vulnerability that allows remote attackers to terminate EngineCore by bypassing logprob_token_ids limits in the Rust gRPC frontend. Attackers can send Generate or GenerateStream requests with output_logprobs enabled and more than 128 output_candidates.token_ids, triggering a fatal sampler exception that crashes the engine.

CVSS 8.2 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • ≥ 0.22.0, < 0.24.0: Affected (semver)
    • 0.24.0: Not affected (semver)

    Update to 0.24.0

  • vllm PyPI

    Versions
    • 0.22.0
    • 0.22.1
    • 0.23.0
    Affected ranges
    • ECOSYSTEM: ≥ 0.22.0, < 0.24.0

    Update to 0.24.0

Original sources

Check your server →