p PatchFirst

CVE-2026-116178

CVE-2026-116178 · vLLM 0.20.0 before 0.30.0 DoS via /inference/v1/generate mm_placeholders

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. Attackers can replay a valid multimodal item with repeated or overlapping mm_placeholders ranges or mismatched kwargs_data and mm_hashes lists, producing a negative text span in Qwen2.5-VL position construction that terminates the engine.

CVSS 8.2 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • ≥ 0.20.0, < 0.30.0: Affected (semver)
    • 0.30.0: Not affected (semver)

    Update to 0.30.0

  • vllm PyPI

    Versions
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.21.0
    • 0.22.0
    • 0.22.1
    • 0.23.0
    • 0.24.0
    • 0.25.0
    • 0.25.1
    • 0.26.0
    • 0.27.0
    • 0.27.1
    • 0.28.0
    • 0.29.0
    Affected ranges
    • ECOSYSTEM: ≥ 0.20.0, < 0.30.0

    Update to 0.30.0

Original sources

Check your server →