CVE-2026-116184
CVE-2026-116184 · OpenRemote before 1.31.0 Cross-Realm Gateway Impersonation via Websocket
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenRemote before 1.31.0 contains an authorization bypass vulnerability that allows realm admins to impersonate gateways in other realms because GatewayService only checks the gateway ID, not the realm. Attackers with WRITE:ADMIN in one realm can create a service user named after another realm's gateway ID to overwrite its descendant assets and open SSH tunnels into its local network.
CVSS 2.1 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
core
- Versions
- ≥ 0, < 1.31.0: Affected (semver)
- 1.31.0: Not affected (semver)
Update to 1.31.0