p PatchFirst

CVE-2026-116688

CVE-2026-116688 · CKEditor: Cross-site scripting (XSS) in the engine package

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 45.0.0 until 47.7.4 and 48.5.1, the engine uses a vulnerable es-toolkit version whose prototype-pollution behavior can be reached while CKEditor processes incoming style attribute values. Crafted editor content can thereby cause unauthorized JavaScript execution in the browser. This issue is fixed in versions 47.7.4 and 48.5.1.

CVSS 8.1 · High · Fix available

Published
Updated

Stack: node

Affected products and versions

  • ckeditor5

    Versions
    • >= 45.0.0, < 47.7.4: Affected
    • >= 48.0.0, < 48.5.1: Affected

    No fix published

  • ckeditor5 npm

    Affected ranges
    • SEMVER: ≥ 45.0.0, < 47.7.4

    Update to 47.7.4

  • @ckeditor/ckeditor5-engine npm

    Affected ranges
    • SEMVER: ≥ 45.0.0, < 47.7.4

    Update to 47.7.4

  • ckeditor5 npm

    Affected ranges
    • SEMVER: ≥ 48.0.0, < 48.5.1

    Update to 48.5.1

  • @ckeditor/ckeditor5-engine npm

    Affected ranges
    • SEMVER: ≥ 48.0.0, < 48.5.1

    Update to 48.5.1

Original sources

Check your server →