p PatchFirst

CVE-2026-11827

CVE-2026-11827 · Insufficiently Protected Credentials in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab EE affecting all versions from 9.5 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user with maintainer-role permissions to obtain another user's stored credentials due to improper authorization controls.

CVSS 4.9 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 9.5, < 18.11.7: Affected (semver)
    • ≥ 19.0, < 19.0.4: Affected (semver)
    • ≥ 19.1, < 19.1.2: Affected (semver)

    Update to 18.11.7; Update to 19.0.4; Update to 19.1.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →