CVE-2026-11854
CVE-2026-11854 · Cross-Site Scripting via Authentication Endpoint Error Message in Multiple WSO2 Products
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The authentication endpoint generates an error message that includes reflected data directly from the request without sufficient sanitization or encoding. This allows an attacker to inject malicious scripts that can be executed in the context of a victim's browser. Successful exploitation enables an attacker to perform actions within the user's browser, such as redirecting the user to a malicious website, modifying the web page's user interface, or retrieving information. However, due to the httpOnly flag on session-related cookies, session hijacking or similar attacks are not possible.
CVSS 6.1 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
wso2 api manager
- Versions
- ≥ 0, < 3.2.0: Unknown (custom)
- ≥ 3.2.0, < 3.2.0.480: Affected (custom)
- ≥ 3.2.1, < 3.2.1.99: Affected (custom)
- ≥ 4.1.0, < 4.1.0.265: Affected (custom)
- ≥ 4.2.0, < 4.2.0.205: Affected (custom)
- ≥ 4.3.0, < 4.3.0.117: Affected (custom)
- ≥ 4.4.0, < 4.4.0.80: Affected (custom)
- ≥ 4.5.0, < 4.5.0.65: Affected (custom)
- ≥ 4.6.0, < 4.6.0.29: Affected (custom)
- ≥ 4.7.0, < 4.7.0.1: Affected (custom)
Update to 3.2.0.480; Update to 3.2.1.99; Update to 4.1.0.265; Update to 4.2.0.205; Update to 4.3.0.117; Update to 4.4.0.80; Update to 4.5.0.65; Update to 4.6.0.29; Update to 4.7.0.1
wso2 api control plane
- Versions
- ≥ 0, < 4.5.0: Unknown (custom)
- ≥ 4.5.0, < 4.5.0.66: Affected (custom)
- ≥ 4.6.0, < 4.6.0.30: Affected (custom)
- ≥ 4.7.0, < 4.7.0.1: Affected (custom)
Update to 4.5.0.66; Update to 4.6.0.30; Update to 4.7.0.1
wso2 identity server
- Versions
- ≥ 0, < 5.10.0: Unknown (custom)
- ≥ 5.10.0, < 5.10.0.399: Affected (custom)
- ≥ 5.11.0, < 5.11.0.446: Affected (custom)
- ≥ 6.0.0, < 6.0.0.272: Affected (custom)
- ≥ 6.1.0, < 6.1.0.274: Affected (custom)
- ≥ 7.0.0, < 7.0.0.155: Affected (custom)
- ≥ 7.1.0, < 7.1.0.65: Affected (custom)
- ≥ 7.2.0, < 7.2.0.26: Affected (custom)
Update to 5.10.0.399; Update to 5.11.0.446; Update to 6.0.0.272; Update to 6.1.0.274; Update to 7.0.0.155; Update to 7.1.0.65; Update to 7.2.0.26