p PatchFirst

CVE-2026-118984

CVE-2026-118984 · OmniRoute 3.8.0 before 3.8.52 Unverified Password Change via /api/settings/require-login

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OmniRoute 3.8.0 before 3.8.52 contains an unverified password change vulnerability that allows holders of manage- or admin-scoped API keys or oma_ access tokens to change the management password without the current password. Attackers can send POST requests to /api/settings/require-login to lock out the operator, take over dashboard login, or disable the login requirement entirely.

CVSS 7.0 · High · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • omniroute

    Versions
    • ≥ 3.8.0, < 3.8.52: Affected (semver)

    Update to 3.8.52

Original sources

Check your server →