p PatchFirst

CVE-2026-119028

CVE-2026-119028 · oapi-codegen 2.0.0 before 2.8.1 Code Injection via Non-String Enum Values

This page contains facts from public vulnerability sources. Check the original advisory before updating.

oapi-codegen 2.0.0 before 2.8.1 contains a code injection vulnerability that allows attackers to inject Go code by supplying non-literal enum entries in integer, number, or boolean schemas. Attackers controlling an OpenAPI document can craft an enum entry that closes the const block in constants.tmpl and injects a func init(), executing code when the generated package is built and imported.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • oapi-codegen

    Versions
    • ≥ 2.0.0, < 2.8.1: Affected (semver)

    Update to 2.8.1

Original sources

Check your server →