CVE-2026-13149
CVE-2026-13149
This page contains facts from public vulnerability sources. Check the original advisory before updating.
brace-expansion through 5.0.6 is vulnerable to denial of service. The expand() function exhibits exponential-time complexity in the number of consecutive non-expanding '{}' brace groups. An attacker who passes a crafted string to expand(), directly or transitively, can cause significant CPU consumption and event-loop blocking. The max option does not mitigate this, as it bounds the output size rather than the recursion work.
CVSS 7.7 · High · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
brace-expansion
- Versions
- ≥ 0, ≤ 5.0.6: Affected (semver)
No fix published
node-brace-expansion Debian:12
- Versions
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Debian:13
- Versions
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Debian:14
- Versions
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 5.0.7
Update to 5.0.7
brace-expansion npm
- Affected ranges
- SEMVER: < 1.1.16
Update to 1.1.16
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.1.2
Update to 2.1.2
node-brace-expansion Ubuntu:18.04:LTS
- Versions
- 1.1.8-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:20.04:LTS
- Versions
- 1.1.8-1
- 1.1.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:22.04:LTS
- Versions
- 2.0.0-1
- 2.0.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:24.04:LTS
- Versions
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:25.10
- Versions
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:26.10
- Versions
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:26.04:LTS
- Versions
- 2.0.1+~1.1.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published