CVE-2026-1615
CVE-2026-1615
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package jsonpath before 1.3.0 are vulnerable to Arbitrary Code Injection via unsafe evaluation of user-supplied JSON Path expressions. The library relies on the static-eval module to process JSON Path input, which is not designed to handle untrusted data safely. An attacker can exploit this vulnerability by supplying a malicious JSON Path expression that, when evaluated, executes arbitrary JavaScript code, leading to Remote Code Execution in Node.js environments or Cross-site Scripting (XSS) in browser contexts. This affects all methods that evaluate JSON Paths against objects, including .query, .nodes, .paths, .value, .parent, and .apply.
CVSS 9.2 · Critical · EPSS 1.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
jsonpath
- Versions
- ≥ 0, < 1.3.0: Affected (semver)
Update to 1.3.0
org.webjars.npm:jsonpath
- Versions
- ≥ 0: Affected (semver)
No fix published
jsonpath npm
- Affected ranges
- SEMVER: < 1.3.0
Update to 1.3.0
Original sources
- https://security.snyk.io/vuln/SNYK-JS-JSONPATH-13645034
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-15141219
- https://github.com/dchester/jsonpath/blob/c1dd8ec74034fb0375233abb5fdbec51ac317b4b/lib/handlers.js%23L243
- https://github.com/dchester/jsonpath/commit/b61111f07ac1a8d0f3133b5fc51438ecb76a6c39
- https://access.redhat.com/security/cve/CVE-2026-1615
- https://bugzilla.redhat.com/show_bug.cgi?id=2437875
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-1615.json
- https://access.redhat.com/errata/RHSA-2026:6308
- https://access.redhat.com/errata/RHSA-2026:59155
- https://access.redhat.com/errata/RHSA-2026:6309
- https://access.redhat.com/errata/RHSA-2026:6802
- https://nvd.nist.gov/vuln/detail/CVE-2026-1615