CVE-2026-16584
CVE-2026-16584 · AWS API MCP Server Security Policy Bypass via Startup Failure
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected. To remediate this issue, users should upgrade to version 1.3.47.
CVSS 7.3 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
aws-api-mcp-server
- Versions
- ≥ 0.2.13, < 1.3.47: Affected (custom)
Update to 1.3.47
awslabs-aws-api-mcp-server PyPI
- Versions
- 0.2.13
- 0.2.14
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 1.0.0
- 1.0.1
- 1.0.2
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.2.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.10
- 1.3.11
- 1.3.12
- 1.3.13
- 1.3.14
- 1.3.16
- 1.3.17
- 1.3.18
- 1.3.19
- 1.3.2
- 1.3.20
- 1.3.21
- 1.3.22
- 1.3.23
- 1.3.24
- 1.3.25
- 1.3.26
- 1.3.27
- 1.3.28
- 1.3.29
- 1.3.3
- 1.3.30
- 1.3.31
- 1.3.32
- 1.3.33
- 1.3.34
- 1.3.35
- 1.3.36
- 1.3.37
- 1.3.38
- 1.3.39
- 1.3.4
- 1.3.40
- 1.3.41
- 1.3.42
- 1.3.43
- 1.3.44
- 1.3.45
- 1.3.46
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- Affected ranges
- ECOSYSTEM: ≥ 0.2.13, < 1.3.47
Update to 1.3.47