CVE-2026-18696
CVE-2026-18696 · Improper Authorization in MongoDB applyOps Command Handling Allows Unauthorized DDL Operations on Collections
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue in MongoDB Server's applyOps command could allow an authenticated user with specific non-default privileges to perform certain data-definition operations, such as dropping or modifying collections, against collections they do not have permission to manipulate. This is due to an inconsistency in how the target collection is determined between the authorization check and the actual operation.
CVSS 7.0 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 8.3.0, < 8.3.8: Affected (semver)
- ≥ 8.0, < 8.0.29: Affected (semver)
- ≥ 7.0, < 7.0.40: Affected (semver)
Update to 7.0.40; Update to 8.0.29; Update to 8.3.8
mongodb Ubuntu:Pro:14.04:LTS
- Versions
- 1:2.4.6-0ubuntu5
- 1:2.4.6-0ubuntu6
- 1:2.4.8-1ubuntu1
- 1:2.4.8-2
- 1:2.4.9-1
- 1:2.4.9-1ubuntu1
- 1:2.4.9-1ubuntu2
- 1:2.4.9-1ubuntu2+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:16.04:LTS
- Versions
- 1:2.6.10-0ubuntu1
- 1:2.6.10-0ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- 1:3.6.3-0ubuntu1.4
- 1:3.6.3-0ubuntu1.4+esm1
- 1:3.6.3-0ubuntu1.4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:20.04:LTS
- Versions
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published