p PatchFirst

CVE-2026-19012

CVE-2026-19012 · Authenticated denial of service in Consul Enterprise-to-Community Edition downgrade path

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

CVSS 5.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • consul

    Versions
    • ≥ 1.18.0, < 2.0.3: Affected (semver)

    Update to 2.0.3

  • consul enterprise

    Versions
    • ≥ 1.18.0, < 2.0.3: Affected; ≥ 1.21.17: Not affected; ≥ 1.22.11: Not affected (semver)

    Update to 1.21.17

  • consul Debian:11

    Versions
    • 1.10.12+dfsg1-1
    • 1.8.7+dfsg1-2
    • 1.8.7+dfsg1-3
    • 1.8.7+dfsg1-4
    • 1.8.7+dfsg1-5
    • 1.8.7+dfsg1-6
    • 1.9.17+dfsg2-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • consul Ubuntu:18.04:LTS

    Versions
    • 0.6.4~dfsg-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • consul Ubuntu:20.04:LTS

    Versions
    • 1.0.7~dfsg1-5ubuntu1
    • 1.4.4~dfsg1-2ubuntu2
    • 1.5.2+dfsg1-6
    • 1.5.2+dfsg1-10
    • 1.5.2+dfsg1-12
    • 1.5.2+dfsg2-14
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • consul Ubuntu:22.04:LTS

    Versions
    • 1.7.4+dfsg1-1
    • 1.8.7+dfsg1-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →